Accessing Clarity Human Services

Supported Web Browsers for Accessing Clarity Human Services

 

Clarity Human Services requires an up-to-date web browser to access all of the software's features. To ensure the latest security features are in place, we strongly recommend always using the latest version of a supported web browser when accessing Clarity Human Services. To find out what browser you are currently using, click here

Bitfocus supports the most recent version of the following web browsers for accessing Clarity Human Services:

*Though Microsoft still supports Internet Explorer for backward compatibility (interoperability with legacy systems), they now recommend using Microsoft Edge.